-
into outfile报错的难题
所属栏目:[MySql教程] 日期:2022-06-27 来源:DaWei
明明有select 权限却报错 mysql select * from server into outfile /tmp/tt.txt; ERROR 1045 (28000): Access denied for user chenliang@% (using password: YES) 百度后需要给file权限 mysql grant file on *.* to chenliang; Query OK, 0 rows affecte[详细]
-
MySQL开启失败
所属栏目:[MySql教程] 日期:2022-06-27 来源:DaWei
MySQL启动失败: 一、错误日志: [mysql@host-172-24-115-217 ~]$ service mysql restart Shutting down MySQL.. SUCCESS! Starting MySQL..180426 13:36:03 mysqld_safe Logging to /usr/local/mysql/data/alert.log. 180426 13:36:03 mysqld_safe Starti[详细]
-
虚拟机centos安装mysql碰见 Couldn t resolve host mirror
所属栏目:[MySql教程] 日期:2022-06-27 来源:DaWei
网上查了一下说是DNS服务器错误。于是修改一下 /etc/resolv.conf 添加一个nameserver 8.8.8.8完成 安装MySql server: 1.下载安装 yum install -y mysql-server 2.服务开启 service mysqld start 3.服务随开机启动 chkconfig mysqld on 4.进入mysql mysql e[详细]
-
启动mysql报错 without updating PID file解决方式
所属栏目:[MySql教程] 日期:2022-06-27 来源:DaWei
编译安装的mysql启动出现报错: Starting MySQL. ERROR! The server quit without updating PID file (/data/mysql/fxq-1.pid). 分析原因: 非正常关机导致: 解决办法: vim /etc/my.cnf 加入一行: innodb_force_recovery= 1[详细]
-
MySQL进阶篇 索引体系区分 B-Tree结构说明
所属栏目:[MySql教程] 日期:2022-06-27 来源:DaWei
MySQL进阶篇 索引体系区分 B-Tree结构说明: 一、索引简介 1、基本概念 首先要明确索引是什么:索引是一种数据结构,数据结构是计算机存储、组织数据的方式,是指相互之间存在一种或多种特定关系的数据元素的集合,例如:链表,堆栈,队列,二叉树等等。[详细]
-
复原mysql slave复制1032错误
所属栏目:[MySql教程] 日期:2022-06-27 来源:DaWei
一台从库出现1032错误,那1032是什么错误,我们看一下 [root@BLAVDP021 ~]# perror 1032 MySQL error code 1032 (ER_KEY_NOT_FOUND): Cant find record in %-.192s 简单说,就是在从库上找不到相应的记录,同时在show slave statusG;中有相关输出,我们看[详细]
-
mysqlbinlog相关简介
所属栏目:[MySql教程] 日期:2022-06-27 来源:DaWei
binlog简介: 二进制日志,记录对数据发生或潜在发生更改的SQL语句,并以二进制的形式保存在磁盘中。 作用: MySQL的作用类似于Oracle的归档日志,可以用来查看数据库的变更历史(具体的时间点所有的SQL操作)、数据库增量备份和恢复(增量备份和基于时间[详细]
-
MySQL迁移文件的小问题
所属栏目:[MySql教程] 日期:2022-06-27 来源:DaWei
线上有一台服务器上,里面有一个mysql数据库服务,其实库也很小,就几个G,一直以来是保留了多天的备份集,但是因为业务的关系,这个库其实只有一些基本的数据查询,但奇怪的是没有从库,一直以来是每天都会备份,保留了近一周的备份集,这种情况也倒相安[详细]
-
MySQL INNER JOIN关联多张表的写法
所属栏目:[MySql教程] 日期:2022-06-27 来源:DaWei
INNER JOIN 关联两张数据表的写法: SELECT * FROM 表1 INNER JOIN 表2 ON 表1.字段号=表2.字段号 INNER JOIN 关联三张数据表的写法: SELECT * FROM (表1 INNER JOIN 表2 ON 表1.字段号=表2.字段号) INNER JOIN 表3 ON 表1.字段号=表3.字段号 INNER JOIN[详细]
-
MySQL架构优化之字符集
所属栏目:[MySql教程] 日期:2022-06-27 来源:DaWei
MySQL应用于大中小企业当中,字符集标准化也是MySQL架构优化中重要的一部分。通常建议中英文混合环境建议选择utf8字符集。 1.操作系统Linux cat /etc/sysconfig/i18n = LANG=en_US.UTF-8 2.MySQL客户端 cat /etc/my.cnf = [client] default-character-set=[详细]
-
MySQL Binlog 技术原理和业务应用案例分析
所属栏目:[MySql教程] 日期:2022-06-27 来源:DaWei
MySQL Binlog用于记录用户对数据库操作的结构化查询语言(Structured Query Language,SQL)语句信息。是MySQL数据库的二进制日志,可以使用mysqlbin命令查看二进制日志的内容。爱奇艺在会员订单系统使用到了 MySQL Binlog,用来实现订单事件驱动。在使用Bin[详细]
-
办公制表常用技巧 学会让你事半功倍
所属栏目:[MySql教程] 日期:2022-06-27 来源:DaWei
办公室工作经常会使用到Excel制表,现在就来给大家介绍几个常用小技巧,让你表格使用起来更加得心应手吧! 1.快速统一日期格式 一张Excel登记表经常到处传阅,导致日期格式不一致,看起来实在杂乱, 这时候我们只需要选定需要统一格式的日期栏,点击工具栏[详细]
-
Mycat分表分库原则
所属栏目:[MySql教程] 日期:2022-06-27 来源:DaWei
分表分库虽然能解决大表对数据库系统的压力,但它并不是万能的,也有一些不利之处,因此首要问题是,分不分库,分哪些库,什么规则分,分多少分片。 原则一:能不分就不分,1000万以内的表,不建议分片,通过合适的索引,读写分离等方式,可以很好的解决性[详细]
-
数据库之锁模块
所属栏目:[MySql教程] 日期:2022-06-27 来源:DaWei
MyISAM与InnoDB关于锁方面的区别: MyISAM默认使用的是表级锁,不支持行级锁 InnoDB默认用的是行级锁,也支持表级锁 InnoDB支持事务,在事务中被加锁的数据行需要 等事务commit之后才会统一解锁,否则不会解锁。而MyISAM不支持事务,所以不会有这个问题 MyI[详细]
-
mysql5.7单实例命令行安装 windows环境下
所属栏目:[MySql教程] 日期:2022-06-27 来源:DaWei
mysql5.7单实例命令行安装: 一.下载安装包 二.解压缩至安装目录 D:install_path 三.添加path环境变量 path=xxx;D:install_pathbin 四.建立参数文件 D:install_pathbinmy.ini 点击(此处)折叠或打开 [client] port=3306 [mysqld] port=3306 basedir=D:[详细]
-
mysqldump原理分析
所属栏目:[MySql教程] 日期:2022-06-27 来源:DaWei
今天学习了下mysqldump原理,具体的结论如下: 1、mysqldump在不加任何参数进行备份的时候: 如果单独备份一个表会对备份表上读锁,直到备份结束unlock,如果备份的整个库,那么会同时lock 这个库下的所有的表,最后在unlock tables,如果备份的是整个实例[详细]
-
可以加快查询运作的是什么属性
所属栏目:[MySql教程] 日期:2022-06-26 来源:DaWei
可以加快查询操作的属性是索引。 利用索引可以加快对数据的查询和排序速度,索引文件作为一个独立的文件进行存储,文件中包含指向表记录的指针,建立索引后,表中记录的物理顺序不变。 相关介绍: 在关系数据库中,索引是一种单独的、物理的对数据库表中一[详细]
-
全新学习MySQL数据库10 MySQL里的那些日志们
所属栏目:[MySql教程] 日期:2022-06-26 来源:DaWei
本文是微信公众号【Java技术江湖】的《重新学习MySQL数据库》其中一篇,本文部分内容来源于网络,为了把本文主题讲得清晰透彻,也整合了很多我认为不错的技术博客内容,引用其中了一些比较好的博客文章,如有侵权,请联系作者。 该系列博文会告诉你如何从[详细]
-
MySQL的server_uuid取得之uuid 函数和uuid_short 函数
所属栏目:[MySql教程] 日期:2022-06-26 来源:DaWei
MySQL的server_uuid取得之uuid 函数和uuid_short 函数: 1、uuid()函数 mysql select uuid(),uuid(); +--------------------------------------+--------------------------------------+ | uuid() | uuid() | +--------------------------------------+--[详细]
-
Java工作流系统-父子流程的配置解说
所属栏目:[MySql教程] 日期:2022-06-26 来源:DaWei
父子流程 关键字: 驰骋工作流程快速开发平台 工作流程管理系统 工作流引擎 asp.net工作流引擎 java工作流引擎. 开发者表单 拖拽式表单 工作流系统 适配数据库: oralce,mysql,sqlserver,Informix, PostgreSQL 达梦 应用背景 在各类工作流项目中,通常会遇[详细]
-
重新学习Mysql数据库5 依据MySQL索引原理进行分析与优化
所属栏目:[MySql教程] 日期:2022-06-26 来源:DaWei
一位阿里 Java 工程师的技术小站。作者黄小斜,专注 Java 相关技术:SSM、SpringBoot、MySQL、分布式、中间件、集群、Linux、网络、多线程,偶尔讲点Docker、ELK,同时也分享技术干货和学习经验,致力于Java全栈开发! 重新学习Mysql数据库5:根据MySQL索[详细]
-
逻辑复制主从创建
所属栏目:[MySql教程] 日期:2022-06-26 来源:DaWei
创建复制用户: CREATE USER repl@192.168.6.% IDENTIFIED BY 123; GRANT REPLICATION SLAVE ON *.* TO repl@192.168.6.%; FLUSH PRIVILEGES; 下面是dump文件中的内容,也就是说备库恢复到这个点。 show warnings;看到密码安全相关的警告... ... 再show sl[详细]
-
phpMyAdmin配置文件中的密文 blowfish_secret 过于短
所属栏目:[MySql教程] 日期:2022-06-26 来源:DaWei
在phpMyAdmin页面上报错配置文件中的密文(blowfish_secret)太短 查看下配置文件more config.inc.php /** * This is needed for cookie based authentication to encrypt password in * cookie. Needs to be 32 chars long. */ $cfg[blowfish_secret] = abc[详细]
-
MySQL分区怎样迁移
所属栏目:[MySql教程] 日期:2022-06-26 来源:DaWei
副标题#e# 需求来源 MySQL越来越流行,而且存储在MySQL的数据量也越来越大,单表数据达亿行已经是非常常见的现象,而这些表里面保存了大量的历史记录,严重影响SQL执行的效率。本文是针对客户需求,迁移MySQL Innodb大表分区中部分历史归档分区到其他实例或[详细]
-
mysql内计算sql语句影响行数的函数
所属栏目:[MySql教程] 日期:2022-06-26 来源:DaWei
SELECT语句中经常可能用LIMIT限制返回行数。有时候可能想要知道如果没有LIMIT会返回多少行,但又不想再执行一次相同语句。那么,在SELECT查询中包含SQL_CALC_FOUND_ROWS选项,然后执行FOUND_ROWS()就可以了: mysql SELECT SQL_CALC_FOUND_ROWS * FROM tbl[详细]
